[WSAS-2072] Session Replication not working when ghost deployment enable Created: 12/Aug/15  Updated: 20/Aug/15  Resolved: 20/Aug/15

Status: Resolved
Project: ZZZ-WSO2 Application Server
Component/s: None
Affects Version/s: None
Fix Version/s: 5.3.0

Type: Bug Priority: Highest
Reporter: Thusitha Dayaratne Assignee: Kasun Gajasinghe
Resolution: Postponed Votes: 0
Labels: None
Remaining Estimate: Not Specified
Time Spent: Not Specified
Original Estimate: Not Specified

Attachments: File wso2appserver-samples-hello-webapp-5.3.0-SNAPSHOT.war    
Severity: Critical
Estimated Complexity: Moderate
Test cases added: Yes

 Comments   
Comment by Kasun Gajasinghe [ 12/Aug/15 ]

Can you provide the steps to re-produce this issue?

Comment by Thusitha Dayaratne [ 13/Aug/15 ]

Steps to reproduce.
1.Upload the sample-helloword webapp attached.
2.Send few requests to the webapp (check what is the worker node that serve the request)
3.Stop the worker node that already serving the request for that webapp
4.Send request to webapp again
5.Count get rest to one (If the replication works count should be continue from the point where it stops the worker node)

Comment by Kasun Gajasinghe [ 17/Aug/15 ]

Session replication is not working in tenant mode as well.. Fixing it properly needs design changes. This is tracked via CARBON-15037 .

In the meanwhile, a fix is provided [1] to get the session replication working in tenant mode when the tenant is loaded in all the instances.

[1] https://github.com/wso2/carbon-deployment/commit/4177fb8f35d1c1a20ffa9059d5835349f25719f9

Comment by Kasun Gajasinghe [ 20/Aug/15 ]


The proper fix is tracked via CARBON-15037

Generated at Sat Feb 29 05:04:42 PST 2020 using JIRA 7.2.2#72004-sha1:9d5132893cc8c728a3601a9034a1f8547ef5c7be.