Uploaded image for project: 'ZZZ-WSO2 Application Server '
  1. ZZZ-WSO2 Application Server
  2. WSAS-1993

Upgrade Eclipse ECJ compiler version to 4.4.2

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Highest
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.3.0
    • Component/s: None
    • Labels:
      None
    • Severity:
      Major
    • Estimated Complexity:
      Moderate
    • Test cases added:
      Yes

      Description

      As per this bug in tomcat [1], the ECJ 4.3.1 JSP compiler that we currently ship in AS is not compatible with JDK 8. So, we need to update the ECJ version.

      The latest version is ECJ 4.4.2. So, we need to do his update in kernel org.wso2.carbon.core.common feature.

      [1] https://bz.apache.org/bugzilla/show_bug.cgi?id=56283

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                thusithad@wso2.com Thusitha Dayaratne
                Reporter:
                kasung@wso2.com Kasun Gajasinghe
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: