Uploaded image for project: 'ZZZ-WSO2 Private PaaS'
  1. ZZZ-WSO2 Private PaaS
  2. PAAS-309

Security group validation error when creating the new security group for the LB.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 4.1.0
    • Fix Version/s: 4.1.1
    • Labels:
      None
    • Severity:
      Major
    • Estimated Complexity:
      Moderate
    • Test cases added:
      Yes

      Description

      Getting the following error with AWS LB extension in VPC environment

      [2015-11-14 10:04:57,632] ERROR - [LoadBalancerExtension] Could not start load balancer
      org.apache.stratos.load.balancer.extension.api.exception.LoadBalancerExtensionException: Invalid security group Id for addInboundRuleToSecurityGroup.
      at org.apache.stratos.aws.extension.AWSHelper.addInboundRuleToSecurityGroup(AWSHelper.java:636)

        Attachments

          Activity

            People

            • Assignee:
              gayang@wso2.com Gayan Gunarathne
              Reporter:
              gayang@wso2.com Gayan Gunarathne
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: