WSO2 Carbon
  1. WSO2 Carbon
  2. CARBON-4486

What is the optimum timeout value required to do a service addition (from a public wsdl) in G-reg?

    Details

    • Type: Bug Bug
    • Status: Resolved Resolved
    • Priority: High High
    • Resolution: Fixed
    • Affects Version/s: 2.0 RC1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      winxp, jdk16
    • Severity:
      Critical
    • Estimated Complexity:
      Moderate

      Description

      I get Readtime out errors when trying to add a service from a public wsdl URL. (public WSDL URL is accessible from a browser). It seems the default timeout value given in axis2.xml is not sufficient.

      [2009-06-22 10:03:06,703] ERROR - Failed to get service details. Read timed out
      org.apache.axis2.AxisFault: Read timed out
              at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
              at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:193)
              at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:75)
              at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:389)
              at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:222)
              at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:440)
              at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:402)
              at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:229)
              at org.apache.axis2.client.OperationClient.execute(OperationClient.java:165)
              at org.wso2.carbon.governance.ui.services.AddServicesServiceStub.addService(AddServicesServiceStub.java:222)
              at org.wso2.carbon.governance.ui.services.clients.AddServicesServiceClient.addService(AddServicesServiceClient.java:71)
              at org.wso2.carbon.governance.ui.services.utils.AddServicesUtil.addServiceContentBean(AddServicesUtil.java:87)
              at org.apache.jsp.services.add_005fservice_005fajaxprocessor_jsp._jspService(add_005fservice_005fajaxprocessor_jsp.java:70)
              at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
              at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:332)
              at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
              at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
              at org.wso2.carbon.ui.JspServlet.service(JspServlet.java:115)
              at org.wso2.carbon.ui.TilesJspServlet.service(TilesJspServlet.java:35)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
              at org.eclipse.equinox.http.helper.ContextPathServletAdaptor.service(ContextPathServletAdaptor.java:36)
              at org.eclipse.equinox.http.servlet.internal.ServletRegistration.handleRequest(ServletRegistration.java:90)
              at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias(ProxyServlet.java:111)
              at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service(ProxyServlet.java:67)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
              at org.wso2.carbon.bridge.BridgeServlet.service(BridgeServlet.java:132)
              at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
              at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870)
              at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
              at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
              at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
              at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
              at java.lang.Thread.run(Thread.java:619)
      Caused by: java.net.SocketTimeoutException: Read timed out
              at java.net.SocketInputStream.socketRead0(Native Method)
              at java.net.SocketInputStream.read(SocketInputStream.java:129)
              at com.sun.net.ssl.internal.ssl.InputRecord.readFully(InputRecord.java:293)
              at com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:331)
              at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:789)
              at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readDataRecord(SSLSocketImpl.java:746)
              at com.sun.net.ssl.internal.ssl.AppInputStream.read(AppInputStream.java:75)
              at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
              at java.io.BufferedInputStream.read(BufferedInputStream.java:237)
              at org.apache.commons.httpclient.HttpParser.readRawLine(HttpParser.java:78)
              at org.apache.commons.httpclient.HttpParser.readLine(HttpParser.java:106)
              at org.apache.commons.httpclient.HttpConnection.readLine(HttpConnection.java:1116)
              at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.readLine(MultiThreadedHttpConnectionManager.java:1413)
              at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java:1973)
              at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1735)
              at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1098)
              at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
              at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
              at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
              at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
              at org.apache.axis2.transport.http.AbstractHTTPSender.executeMethod(AbstractHTTPSender.java:550)
              at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:189)
              ... 41 more

      Steps to reproduce:
      ================
      1. Click on add-->service
      2. Enter a name, namespace and public wsdl url such as http://www50.brinkster.com/vbfacileinpt/np.asmx?wsdl

      After a few minutes, I was directed to a system error page.

        Activity

        Lahiru Gunathilake
        added a comment -
        This depends on the time we talk to download required artifacts to import the wsdl... this really depends on the wsdl.. it it's importing lot of more wsdls and schemas it will take time. we can simply document this for users if they are having readtime out they have to increase the timeout value.
        Show
        Lahiru Gunathilake
        added a comment - This depends on the time we talk to download required artifacts to import the wsdl... this really depends on the wsdl.. it it's importing lot of more wsdls and schemas it will take time. we can simply document this for users if they are having readtime out they have to increase the timeout value.

          People

          • Assignee:
            Senaka Fernando
            Reporter:
            Charitha Kankanamge
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: